Common Errors in Digital Signature operations
- 1.1 Invalid credentials on certificate CA access
- 1.2 Invalid certificate access account
- 1.3 Error on certificate CA access
- 1.4 Invalid parameters on signature requests
- 1.5 Error on timestamp server access
- 1.6 Error using the signing certificate
- 1.7 Error on custody server access
- 1.8 Internal error in the signature operation
- 1.9 Document is write protected or read-only
- 1.10 PDF document doesn’t support digital signatures
- 2 Sign’Stash support channels
Below, we cover the most common errors that can occur during the use of Sign’Stash services, detailing what each signature error means and the possible solutions to these issues.
You can access the document details page via Backoffice to consult the error related with the operation:
Invalid credentials on certificate CA access
This error indicates that the credentials used to access the certification service are invalid or have expired.
Causes:
The certificate access credentials may have expired and need to be renewed.
Solution:
Verify if the certificate access account is correct. Certificate not associated with Multicert client account
Confirm that the certificate access has not expired, and if so, renew the access. Renew Access to Certificate Authority | Renew certificate authority access credentials
If the issue persists, contact the specific Sign’Stash support channels.
Invalid certificate access account
This error suggests that the account configured to access the certification service is not valid.
Causes:
The configured account may have been deactivated or removed.
The access may have been configured incorrectly, pointing to an invalid account.
Solution:
Check if you used the correct Multicert account during the certificate access configuration. Certificates Management
If the issue persists, contact the specific Sign’Stash support channels.
Error on certificate CA access
This is a generic error indicating that there was a problem accessing the certificate service.
Causes:
It could be a temporary failure of the service.
Network or infrastructure issues.
Solution:
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
Invalid parameters on signature requests
This indicates that the signature request contains errors in its configuration.
Causes:
Required fields may be missing in the signature request.
Fields may be incorrectly configured.
Solution:
Check if the parameters passed in the signature request are correct. If you have questions about the parameters, please refer to the Swagger documentation provided by Sign’Stash. Connecting your service | API Definition and Examples
If the issue persists, contact the specific Sign’Stash support channels.
Error on timestamp server access
There was an error in the service responsible for processing the timestamp during the signature operation.
Causes:
The timestamping service may be unavailable or offline.
Solution:
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
Error using the signing certificate
This error occurs when there is an issue with the certificate used to perform the signature.
Causes:
The certificate used may have expired or been revoked.
Solution:
Check the validity of the certificate, confirming if it is still within its validity period and has not been revoked. Certificates Management
If necessary, renew or replace the certificate with a new one. How to recreate the "Principal" wallet and change the Multicert account
If the issue persists, contact the specific Sign’Stash support channels.
Error on custody server access
There was an error in the service responsible for storing the signed document.
Causes:
Connectivity issues with the storage service.
The storage service may be offline or experiencing failures.
Solution:
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
Internal error in the signature operation
This indicates an internal error during the signature operation.
Causes:
It could be an internal failure in the services performing the signature.
Solution:
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
Document is write protected or read-only
This error indicates that the document cannot be modified because it is either write-protected or in read-only mode.
Causes:
The PDF document was generated with protection against writes and the system can’t apply a signature to it.
Solution:
Generate the document withoutThis error indicates that the document cannot be modified because it is either write-protected or in read-only mode. write protection.
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
PDF document doesn’t support digital signatures
This error means that the PDF format being used does not allow digital signatures.
Causes:
The PDF document was generated with an older version (e.g. 1.2 or older) that doesn’t support digital
Solution:
Generate the document with PDF version 1.3 or newer.
Try again after some time. If the issue persists, contact the specific Sign’Stash support channels.
Sign’Stash support channels
Enviroments | Support channel |
---|---|
Staging (https://staging.must.digital/signstash) | |
Production (https://msignstash.multicert.com/signstash ) |
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